(BETA VERSION! This tutorial is in beta. If you have feedback, please post them in this thread in the TroikaTronix forum.)

This tutorial explains how to use Isadora to play movies with multichannel or surround sound audio tracks on macOS. 

The first step is to have a movie that has multichannel audio tracks. Most video editing software such as Final Cut Pro X or Adobe Premiere have the ability to prepare movies with multichannel sound. It is beyond the scope of this tutorial to explain how to do that with every software program out there. But we will offer a very brief example of one way to do it with Final Cut Pro X.

Preparing a Surround Sound Movie in Final Cut Pro X

The example that follows is just one way to prepare a movie for multichannel audio output. A Google search will lead you to additional examples.

  1. First, you will want to create a new project, ensuring that you choose "Surround Sound" in the popup next to the "Audio Channels" prompt.
  2. In this example, we will add a single video track and six individual mono files to the project. When you add mono sound files in FCPX, you are able to route each channel to the individual surround sound outputs. After importing the media and adding it to the project, our layout looks like this.
  3. Now, you can click on each individual audio track and adjust the channel routing in the inspector view at the top right. For our example, we routed each of the six mono audio tracks to one of the six possible Surround Sound output channels.
  4. As you are inspecting the audio channels, click also on the "Info" tab of the Inspector window. You'll see that, by default, the audio has been assigned a "role" as dialogue. You do not need to change this for this example, but assigning different roles does allow for different mixing possibilities when exporting the final movie.
  5. Once the channel assignments are made, choose File > Share >  Master File... to export the movie. In the dialog that appears, click on the "Settings" tab. Then click on the popup next to the prompt "Roles as:" and choose "Multitrack Quicktime Movie." You will see that a new set of options appears.
  6. You'll see a popup menu that says "Video". Below this, and a single popup labeled "Dialogue" which should have another popup to it's right that already says "Surround." You do not need to change these settings for this example.
  7. Click "Next..." to show the Save file dialog, name the file, and click the "Save" button.
  8. The resulting file will be a multichannel audio file, with the six audio tracks assigned to the surround sound channels you selected in Step 3.

Inspecting and Adjusting Channel Routings using QuickTime Player 7

NOTE: this section is not possible if you are running MacOS Catalina, because it will not run 32-bit applications like QuickTime Player 7.

Before you begin, you need a copy of the old QuickTime Player 7 from Apple. The newer QuickTime Player X does not offer the audio features we are about to describe. You can download QuickTime Player 7 here: https://support.apple.com/kb/dl923?locale=en_US

The reason we are using this old program is that is offers the ability not only to view the channel assignments, but to easily change them.

  1. Open a multichannel audio movie in QuickTime Player 7. (If you exported a movie using FCPX in the example above, you can open that movie.)
  2. Choose Window > Show Movie Properties
  3. In the window that appears you will see the various tracks in this movie file. Click the one that says Sound Track.


  4. Once you so this, you will be able to see the channel assignments on the bottom right portion of the window. If you are working with the FCPX created above, you'll see the channel assignments you made in Step 3 of that example.
  5. Each of these channel assignments names is in fact a popup menu. If you click on one of the them you can re-route it to a different channel assignment by choosing the desired channel from the popup menu.
  6. If you do make changes to the channel routing, you will need to choose File > Save to save the new channel assignments.

Preparing your Computer for Multichannel Sound Playback

The crucial thing to understand about multichannel audio movies is that the operating system uses the channel assignments stored in the movie file to automatically be send the audio to the proper output on your multichannel output device. It can only do that if you've configured the multichannel output device on your computer using Apple's Audio Midi Setup utility.

To setup your computer for multichannel audio output, do the following:

  1. Connect your multichannel audio device to the computer.
  2. Open the Audio Midi Setup application found at /Applications/Utilities
  3. Make sure you can see the "Audio Devices" window. If you do not see it, choose Window > Show Audio Devices
  4. If your hardware was recognized, it will be shown in the list of audio devices at the left side of the window. If not, check that it is connected to the computer, that it is powered on, and that the necessary drivers (if necessary) are installed.
  5. Right-click your hardware device and choose Use this device for sound output from the menu. This makes your hardware device the default audio output. (For this example, we're using a virtual multichannel audio device called "SoundFlower (64ch)".) Note that you are not required to make the multichannel audio device the default output, because you can also choose to play movies using specific audio hardware in Isadora. See the section Playing Multichannel Sound in Isadora below for more details.
  6. Right-click your hardware device again and choose "Configure Speakers..." to show the speaker configuration dialog.
  7. Click the "Multichannel" button at the top left of the Window, and then choose "5.1 Surround" in the popup menu to the button's right. Your configuration window should now look like this.
  8. In this window, you have the opportunity to see and/or change the routing between the channel assignments (e.g, left front. right front,, center, etc.) to the physical output on the audio hardware (e.g., output 1, output 5, output 12, etc.) The defaults for the surround sound setup:

    left front = output 1
    right front = output 2
    center = output 3
    subwoofer (aka LFE Screen) = output 4
    left surround = output 5
    right surround = output 6


  9. Once you are finished with the Speaker Configuration, click the "Apply" button (if you made changes) or click "Done"

Your Mac is now prepared to play multichannel output through your multichannel audio device.

Using the "Geometric" Speaker Configurations in Audio Midi Setup

Apple's Audio Midi Setup program also offers three "geometric" speaker configurations: Quadraphonic, Hexagonal, and Octagonal if you have four-speaker, six-speaker or eight-speaker setups.

If you wish to use these configurations, then you must use the channel assignments Discrete-0, Discrete-1, etc., when preparing the movie in QuickTime Player 7.

At this time, we do not know of an automatic procedure to set these channel assignments when exporting movies from Final Cut Pro X, Premiere or other programs. You must set them manually in QuickTime Player 7.

Playing Multichannel Sound in Isadora

Once you have configured your computer, playing your multichannel sound movies in Isadora is, generally speaking, automatic.

  1. Import the multichannel audio movie you've been working with during this tutorial into Isadora. If you're using an existing file, it is very important that you examine the audio routing in the movie using Quicktime Player 7 if possible. Ensuring that the channel assignments are set up as you expect will save you a lot of debugging time later!
  2. Drag the movie into the scene editor to play it. Because the channel assignments are saved with the movie, and because you specified the speaker configuration in the section Preparing your Computer for Multichannel Sound Playback above, the individual audio channels will automatically be sent to the correct output on your audio output device.

If you chose not to make your audio output hardware the default device in Step 5 of Preparing your Computer for Multichannel Sound Playback, you will want to choose the audio output device in the Movie Player. However, the input that allows you to do this is not visible by default. You must explicitly choose to show it.

  1. Double-click the "Eye" icon on the Movie Player actor to show the Show/Hide Actor Properties dialog.
  2. Enable the 'audio device' input by clicking the checkbox next to its name.
  3. Click "OK" to close the dialog. The 'audio device' input will now be available in the Movie Player actor.
  4. To select the audio device to which this Movie Player will send it's audio, click the box to the left of the word 'audio device' in the Movie Player actor.
  5. A popup menu will appear displaying all of the audio output devices connected to the system.
  6. Select the desired audio output hardware from the popup. The sound for the currently playing movie will now be sent to that output device instead of the default output device.