Jump to the Isadora 3.0.6 Release Notes

Jump to the Isadora 3.0.2 Release Notes

General Information about Isadora 3

Isadora 3 Pricing

Please see this support article for Isadora 3 pricing information. 

Please see this support article for information on how to apply for the academic discount. 

Updated TroikaTronix Support Policy

Please see this support article for the updated version of the TroikaTronix’s Support Policy.

Please note that as of the release of Isadora 3, Isadora 2.6.1 is the only version of Isadora 2 for which we will be providing technical support. 

System Requirements

Please check out this support article for the full details on Isadora 3’s System Requirements.

Summary:

If you are running macOS 10.15 Catalina, you must work with Isadora v3.0.6 or later. Earlier versions of Isadora 3 and Isadora 2 are not supported on Catalina.

Isadora 3 will run on almost any contemporary Mac or Windows computer, however, your system requirements may vary based on the scope of your project. 

Isadora is not supported on tablet devices such as the Microsoft Surface Pro, Linux machines, and systems which run macOS on non-Apple hardware.

Isadora is not designed for use with external graphics cards (eGPUs) or machines that have multiple discrete GPUs. 

Running Isadora on machines utilizing unsupported hardware configurations may have unexpected and undesirable results in terms of performance and usability.

We recommend you carefully research computer equipment to find the best option for your project needs and budget. If you’re looking for help finding the right computer, feel free to post on the TroikaTronix Community Forum to ask for suggestions.

Isadora 3.0.6 and macOS Catalina (v10.15) 

We are confident to recommend Isadora 3.0.6 to Catalina users who are developing new pieces, or using it in workshops or teaching environments.

However, like many industry leaders, we strongly advise you to hold off on upgrading to Catalina if you are working in a professional performance environment. Because of substantial changes to security protocols in Catalina, and because of numerous, serious issues this new version of macOS exhibited during its development cycle, we feel you should wait for a few more updates to come out before you make the switch.


Using Isadora on a Windows Laptop

Windows users on laptops should should follow the steps in this support article to properly configure their computers before working with Isadora.

Most Windows laptops with dedicated graphics cards also have integrated Intel graphics chips and energy saving features, (which are enabled by default), that dynamically switch which graphics card any given application is using based on its current performance requirements. This process of switching graphics cards on the fly causes problems with Isadora (and a number of other live video applications).

In order to run Isadora properly on a Windows laptop with both a dedicated and integrated graphics card you must configure your computer to utilize only your dedicated graphics card for Isadora.

New Isadora 3 Manual

Please see this link for the new Isadora 3 Manual.


TroikaTronix Digital Sponsorship Program

We will launch the TroikaTronix Digital Sponsorship program, and release and update to Isadora 3, during the summer at Isadora Werkstatt Berlin 2019.

Artists who need Isadora but cannot afford to pay full price for a license can request a year-long subscription to Isadora on a sliding price scale. We are still working out the exact details, but in general terms, it will work like this:

Artists who wish to apply for the sponsorship will have to answer the following questions:

  1. What do you plan to do with Isadora?
  2. How will Isadora affect your artistic practice in the coming year?
  3. When people pay for Isadora, we use the income to make the software better. If no one paid, we'd eventually have to close our doors. With this in mind, why do you feel that we should give you a discount?
  4. How much can you afford to pay? (Here, there will be a pop-up menu showing prices ranging from 10% to 90% of normal price.)

We will select our sponsored artists based on their need as well as the sincerity and passion with which they answer these questions. At the end of the year-long sponsorship, the sponsored artists will be required to share their resulting discoveries and experiments with Isadora users on the TroikaTronix Community Forum and social media. The artists who participate in the TroikaTronix Digital Sponsorship program will also be required to credit the sponsorship program and TroikaTronix if the artist's work is exhibited publicly/on social media or featured in any news coverage. (This also applies to subsequent works that are derived from what the artist developed while participating in the TroikaTronix Digital Sponsorship program.)


New TroikaTronix Plugin Page

We have created a new page on the TroikaTronix site specifically for sharing Isadora Plugins, Patches, Themes, and User Actors/Macros. We will have a short knowledge base article prepared about this in the near future.

All official TroikaTronix Plugins will be uploaded there, including Rutt-Etra, the TroikaTronix GLSL Shaders, the TroikaTronix FFGL Plugins, and the Artnet Plugins. It is staff-moderated and user-submissions are very much encouraged!

This is also where we will be uploading various other plugins, (such as the  depth-map camera plugins, body-tracking plugins, NDI input plugins, and PJ Link plugins), as they are completed.


New Licensing System

Licenses for Isadora 3 are cross-platform(!) and can be activated and deactivated on a computer within the program itself and can also be deactivated through our new License Portal, giving users the power to easily move a license between their computers as needed.

If you upgrade to Isadora 3, any existing Isadora 2 and/or Isadora 1 license(s) you own will remain valid so that you can always go back and work on your legacy projects in their original version. We plan to release a version of Isadora 2 that will use the new licensing system so that license management will be easier for all users running legacy Isadora 2 projects in the future.

License Portal

Please see this support article to learn about the new License Portal.

Isadora 3 License Types

Choose which license type is right for you:

Monthly and Yearly Subscription

A monthly or annual subscription to Isadora. While your subscription is active, your license is automatically upgraded to the latest version of Isadora. This option is ideal for independent designers who work with Isadora on a regular basis. For each Subscription license you purchase you can activate Isadora on up to two computers, though you may use only one of those two computers at a time.

7-Day Rental

Activates Isadora for a 7-Day rental period. Each Rental license you purchase allows you to activate Isadora on one computer. This option is ideal for short-term uses such as experimenting with a licensed copy of the program before purchasing a full license, operating Isadora for the run of a production, or for the participants of workshops.

Buy-to-Own: Isadora 3 Perpetual License

Once you activate Isadora on a computer with a Perpetual license it will work on that machine forever, (except if you reformat your hard drive or deactivate the license on that computer). Please note that moving from Isadora 3 to the next major release of Isadora will be a paid upgrade for buy-to-own licenses. For each Buy-to-Own license you purchase you can activate Isadora on up to two computers, though you may use only one of those two computers at a time.

Buy-to-Own: Isadora 3 USB Key License

Ideal for bouncing between multiple computers that don't have internet access or for universities that wish to have licenses that students can "sign out" and return. The USB Key only allows you to run a licensed version of Isadora when it is plugged into the computer you are using, but you can move it easily between computers that do not have internet access. 

If you already have an Isadora USB Key license, you do not need to buy a new USB Key for Isadora 3; you only need to purchase the upgrade to Isadora 3. (7-Day, Monthly, and Yearly licenses cannot be tied to a USB key!)

Upgrades

Users with a buy-to-own license for a prior Isadora version can upgrade to the current version at a discounted rate. (Existing licenses cannot be converted to the subscription model.)


New Feature: Stage Setup

Isadora 3 features the new Stage Setup, introducing extremely flexible control of video output. This all-new, highly configurable interface allows you to send the same video to multiple projectors simultaneously, show a different video on each, composite several videos together, or any combination in between. 

Quick Start Guide

Please see this support article for the quick-start guide for the new Stage Setup.

Stage Setup Replaces Stage Preferences

The old Stage Setup and Stage Live Edit now exist in the new Stage Setup and all of the settings for making and adjusting stages have removed from Isadora > Isadora Preferences > Stages and moved to Output > Stage Setup.

Keyboard Shortcuts

Cmd/Ctrl+2 opens the new Stage Setup (just like the keyboard shortcut for the old Stage Setup).

Pressing +/- will zoom in and zoom out on the Layout Editor View.

Stages and Displays

The new Stage Setup system allows: 

  • Up to 48 Stages total 
  • Up to 16 Stages (1 display per Stage)
  • Up to 16 physical displays
  • Multiple displays to be assigned to a single Stage
  • Up to 48 Virtual Stages
  • Automatic blending and manual adjustment of curves.
  • Keystoning and flipping
  • Custom sizes for Stages, displays, and their floating preview windows.
  • Splitting a display into halves, thirds, and quarters
  • Syphon/Spout, Blackmagic, and NDI output of Stages and displays.

New Stage Type: Virtual Stages

Virtual Stages are Stages that have with no physical displays assigned to them.

The new Get Stage Image actor can be used to pull content rendered to Virtual Stages back into your patch. You can also send content to Virtual Stages for the express purpose of recording it to disk.

As part of the implementation of Virtual Stages in Stage Setup, the “Virtual Stage” actor has been renamed “3D Renderer” in Isadora 3.

Assign Multiple Displays to a Single Stage

The new interface lets you assign multiple displays to a single Stage and automatically blend them.

Arrow Keys for Precision Adjustments

When adjusting the placement of multiple Displays assigned to a single Stage, you can click on the Stage in the Layout Editor View and use Arrow keys to move them. (Without shift is one unit [pixel], with shift is 10.)

Stage List

The Stage List along the left side allows you to add, delete, duplicate and re-order Stages, the total resolution of each Stage, and what displays are assigned to each Stage.

You can also rename Stages to your liking. The Stage names conveniently show up in all your Projector actors so it's easy to remember which Stages are for which video surfaces.

The bottom of the Stage List is also where you can find the button for the Blend Maker.

Blend Maker

Mark added a major feature in the form of a Blend Maker with numerous options.

Resizing and Splitting

Both Stages and displays can be assigned custom resolutions, as can their floating preview windows.

Displays can be divided into halves, thirds, or quarters to support a wide range of hardware such as the Matrox TripleHead2Go and the Datapath Fx4.

Stage/Display Output via Syphon/Spout + Blackmagic and NDI

You can now output the content from any Stage or display via Syphon/Spout, Blackmagic device, or NDI! (NDI Input will be available as a plugin soon!)

Keystoning and Flipping 

You can keystone and flip each individual display directly in Stage Setup.

You can also flip each Stage or display’s output.

A use-case for flipping the displays: your projector settings aren't correct, you don’t have a remote, and you don't want to physically touch the projector to change the flip.

Display Overview

Please see this support article for information the optimal way to configure your system's displays for the best performance.

At the top right of the Stage Setup, click on the button that says "Show Display Overview" to see how your computer’s displays are configured, their display numbers, general identifying information, and refresh rate.

OpenGL Info Buttons

If you click the OpenGL Info button at the bottom right of the Stage/Display Settings, it will give you info about the fullscreen window, the preview window, or both (if both exist). (The OpenGL info features have been removed from Isadora Preferences.)


New Feature: IzzyMap Numeric Point Editing

Mark added the oft-requested numeric editing of mapping points in IzzyMap!!!


Threaded Media Engine

The entire media engine runs in a separate "thread" or process from the main, user interface thread. This is a major development because, for Isadora's entire history, the engine and the user interface ran in the same process. That mean delays in handling the user interface (i.e., drawing the actors) could glitch or otherwise interrupt the multimedia engine. But no more!

For example, on macOS, when you choose a menu item from a menu with the mouse, the operating system fades out the menu image over 200 mS period. In the past, that would have caused a 200 mS glitch in the playback. But now, since the user interface thread and the playback thread are separate, this unacceptable interruption will not happen.

Important: You may notice that the number of cycles shown in the display is slightly less than you've experienced in the past; don't let this concern you. It has to do with the way in which the timers fire in the threaded system. The key thing to pay attention to is the frame rate. This should be very solid, even if you do things that would have caused problems in the past, like madly scrolling the Scene Editor when it has lots of actors in it.

Playback Improvements

Mark did a lot of work “under the hood” that improved video playback. This includes:

  1. Stability improvements for the AVFoundation ('performance') background movie player on Mac.

  2. Windows Media Foundation playback addition/improvements on PC.

  3. Mark updated the HAP in AVFoundation framework to the very latest version and created an updated version of the Hap Codec for Mac and PC.

  4. H265 movies now play on PC, but we are still in the process of optimizing this

    • The typical extension for these is MKV, which has been added as a possibility on Windows but not on macOS.

    • AVFoundation will not play these MKV movies.

    • QuickTime will play the audio, but the video is black.

Recommended Formats for Video Media Playback

We recommend the formats listed below because they have been extensively tested by our team, and demonstrate the best possible performance and cross platform compatibility:

  1. hap.mov

  2. hapQ.mov (High Quality)

  3. hapA.mov (Alpha Channel)

  4. hap.avi

  5. hapQ.avi (High Quality)

  6. hapA.avi (Alpha Channel)

  7. photoJPEG.avi

  8. photoJPEG.mov

  9. Apple ProRes 442.mov (macOS only)

  10. Apple ProRes 4444.mov (macOS only, Alpha Channel)

  11. .wmv (Windows only)

  12. H264.mp4 (Does not support interactive playback, e.g. reverse speeds or scrubbing)

  13. H264.mov (Does not support interactive playback, e.g. reverse speeds or scrubbing)

  14. Mp3 - Audio only

Cross-Platform Movie Compatibility Options

On Windows, the installer now downloads the requisite redistributables as well as the GDCL MPEG-4 DirectShow Filter from Renderheads. You will find that many MOV formats will play fine using DirectShow under windows. Most importantly this includes HAP, but also we had success with MP4, Photo JPEG and DV. Other Apple specific codecs like Apple ProRes and the Animation codec will not play. Similarly the Mac version can play Windows AVI files in a variety of formats, including HAP, Photo JPEG, and DV. 

Importantly, Mark discovered that the HAP codec for Windows is woefully out of date. There are two entire formats that it would not play. Mark fixed one of those two, and that brought it into closer alignment with the Mac codec. (TroikaTronix will create our own Github for the Windows HAP codec so you and others in the world can benefit from Mark’s work on this.)

Isadora 3 is 64-bit

Isadora 3 underwent a massive overhaul to the entire code-base of the application to ensure its future longevity. This translates to future-proofing Isadora (as macOS 10.15 Catalina will not run 32-bit programs), faster processing, better performance and frame-delivery, and importantly, the removal of many deprecated 32-bit QuickTime elements. 


Blind Mode

Isadora 3 implements a long-requested feature: Blind Mode! 

It's at the top of the Scenes menu (which also displays the keyboard shortcut ) and functions like blind mode on a lighting console, allowing you to keep running cues in one Scene while editing a different, inactive Scene without having the Scene you're editing show up in the output. You can even use Go Triggers and/or Keyboard Watchers and Jump actors to keep activating other Scenes while you’re editing an inactive Scene in Blind Mode! 

Please note that in 3.0.1 you can only edit inactive Scenes using Blind Mode; if you have Blind Mode targeting your currently active Scene, any changes you make are live.


New Linking Features

Detach Link at Input and Detach Link at Output

Cmd + 3 will now detach all currently selected links from a single input, allowing you to reattach them to a different input. 

Cmd + 4 will now detach all currently selected links from a single output, allowing you to reattach them to a different output. 


Auto-Heal

In Isadora 3, if you delete a video actor between two other video actors the connection will automatically “heal” itself (and the output won’t go black!)

Grey "Ghost" Line

In Isadora 3, if you detach one end of a link, the connection is not broken (meaning video will not cut to black while you’re re-patching something). A grey “ghost” line remains behind to indicate this.

Non-Linkable Inputs

Mark has introduced a new 'port' input that does not allow you to connect it to something else. The reason for this is that there are some actors (such as Javascript, Selector, Router, etc.) that have an input parameter which allows you to change the number of inputs/outputs they have. One should never have been able to link other things to these inputs; interactively controlling the number of inputs/outputs wasn't very useful and could have potentially caused crashes. Thus, these specific parameters now cannot be linked to other actors. This type of input parameter is now easily identifiable as the circular node, (to which one would normally attach links from other actors), has been replaced by a triangle.

This change has been made to specific inputs on the following actors: 

  1. Blob Minimum Distance

  2. Blob Target Proximity

  3. Classic Data Array (Deprecated)

  4. Data Array

  5. Envelope Generator

  6. Envelope Generator++

  7. Get Global Values 

  8. Hold Range 

  9. JavaScript 

  10. Key Table Watcher 

  11. LanBox Channels 

  12. Lookup 

  13. Matrix Value Send 

  14. Max Value Hold 

  15. Maximum

  16. Mini Sequencer 

  17. Min Value Hold 

  18. Minimum

  19. Movie Player

  20. Classic Movie Player (Deprecated)

  21. Classic CI Movie Player (Deprecated) 

  22. Classic Texture Movie Player (Deprecated)

  23. Classic Movie Player Direct (Deprecated) 

  24. Classic Sound Movie Player (Deprecated)

  25. OSC Multi Listener

  26. OSC Multi Transmit

  27. Pulse Generator

  28. Router

  29. Selector

  30. Send Raw Midi

  31. Send Serial Data

  32. Send Sys Ex

  33. Sequential Trigger

  34. Set Global Values

  35. Simultaneity

  36. Sound Level Watcher++

  37. Table

  38. TCP Send Data

  39. Text Formatter

  40. Timed Trigger


New Feature: Movie Player Timecode

You can now use timecode with the Movie player. Want to jump to the 30-second mark in your video? If you've got it set to use timecode, you can just type "30,0" into the position input to go to 00:00:30:00 (Hours:Minutes:Seconds/Frames)

New Movie Player Menu Options: Use Timecode and Use Percentage

The Movie Player actor can now use Percentage (as in Isadora 2.6.1 and earlier) or Timecode for "position" (input and output), "play start", and "play length"! 

Remember that this conversion is not lossless. There really isn't any way around the fact that you need to reset the 'scale min' and 'scale max' as well as [obviously] the absolute min and max for the time values when you switch between Timecode and Percentage. If you undo this operation however, you should end up with exactly what you had before.

In the Scene Editor, simply right-click on a Movie Player actor and select "Use Timecode" and "Use Percentage" to switch between these two modes. Provided that there are no other actors in the way, the Movie Player will also automatically shrink and expand itself so that you can see the full timecode (or percentage) value.


In Timecode mode, the Movie Player's "play length" parameter will change to "play end"; the total length of the movie file.

If you change the "play end" value to be greater than the full length of the movie file, the value will turn red to indicate that something is amiss.

Manual Playhead and Position Adjustment

You can now move the loop points by dragging the two triangles above the green bar at the bottom of the Movie Player actor. This is the same as entering values into the the 'play start' and 'play length' inputs and is undoable.

You can now jump a movie to a specific point by double-clicking on that portion of the green bar.

Play, Stop, Pause, and Mute Buttons!

To improve quality of life and allow for rapid-response in a rehearsal setting, Mark added play, stop, pause, and mute buttons at the bottom right-hand corner of the Movie Player actor:

  • Play - If the movie is stopped (unloaded), then start it will start up again. If the movie is paused, it will be unpaused.

  • Stop - Unload the movie. (This has the same effect as setting visible to off.)

  • Pause - Set the movie speed to zero.

  • Mute / Unmute - Click the button to set the volume of the Movie Player to 0. Click it again to restore the volume specified in the 'volume' input.

Note that none of these settings are persistent! If you leave the scene and come back, they are all reset to whatever the 'visible', 'speed' and 'volume' inputs say at the actor's inputs. Additionally, these buttons will not appear on a Movie Player that does not have media loaded into it.


New Feature: MIDI Timecode Support

Isadora 3 adds input support for MIDI Timecode (MTC)!

Once you go to Communications > MIDI Setup and select the source of your MIDI Timecode, you can use the MTC reader to make use of the incoming MTC data

New Timecode Display

The new Timecode Display is at the bottom right of the main application window. This will show "--:--:--:--" if no Timecode is being received or if it's invalid somehow, or the current timecode input if valid MTC is being received.

Along with displaying HH:MM:SS, the timecode value has an internal field that indicates the timecode rate. For a new actor, the rate setting for all timecode values is set to "document default", as set in this pop up menu.

New Data Type: Timecode

Timecode is its own data type now, like float, integer, string, etc. 

These are the supported frame rates:

  • 23.976 
  •  24 
  •  25 
  •  30 Drop Frame (29.97) 
  •  30 
  •  50 
  •  59.94 
  •  60   

The new data type gives you some big advantages in terms of conversion:

  • If you connect a timecode output to a float input, the value is converted to seconds. 

  • If you connect it to an integer input, the value is converted to frames. 

  • If you connect it to a string input it is converted a string representation as HH:MM:SS/FF. 

  • When entering MTC values commas or semicolons can be used as placeholders for "00" (just like AfterEffects!):

    • 30,0 = 00:00:30:00 

    • ,1,30, = 00:01:30:00 

    • 1,1,30,0 = 01:01:30:00 

    • 30,15 = 00:00:30:15 

    • 2,45,7 = 00:02:45:07 

    • 2,,0 = 00:02:00:00 

    • 2,,15 = 00:02:00:15

  • Add a forward slash to specify framerate: 

    • 30,0/3 = 00:00:30:00/30

    • 45,0/6 = 00:00:45:00/60

Mixing Timecode Rates = Confusion

It's best to make sure that all of your video media uses the same frame rate as your incoming MIDI Timecode. 

While we HIGHLY recommend you match all of your media frame rates to your MTC rate, but if you are a masochist and want to work with mismatched rates, things like the Timecode Comparator should be up to the task (in certain cases). For example 00:00:00:05/30 (five frames into a movie that runs at 30 frames per second) is equal to 00:00:00:10/60 (ten frames into a movie that runs at 60 frames per second), so this Timecode Comparator actor will trigger at the correct time.

Just remember that 30 seconds and 15 frames into a 30fps movie is not the same as 30 seconds and 15 frames into a 60fps movie!

00:00:03:15/30 =/= 00:00:30:15/60

00:00:03:15/30 = 00:00:30:30/60

One solution for this problem is to internally work with all timecode locations as seconds instead of timecode. (If you connect a timecode output to a float input, the value is converted to seconds.) This solves the comparison issue of dealing with two frame rates that are different since you can convert them into a precise time value measured in seconds, then compare them.

The Timecode Calculator, MTC Compare, and MTC Movie Locker actors also use the new MIDI Timecode data type and are quite useful for working with timecode.


Plugin Updates

Please note that any 3rd-party FF, FFGL, or custom Isadora plugins will have to be 64bit in order to work with Isadora 3.

The previous 32bit FreeFrame effects cannot be loaded, so the official TroikaTronix FFGL Plugins have been updated to 64-bit format and uploaded to the TroikaTronix Plugin Page.

Do NOT mix 32bit and 64bit plugins in your plugin folders for Isadora 2 or 3 (this can cause issues when you launch the program!)

Please see this support article detailing where to install new plugins for Isadora 2 and 3 on Mac and Windows.

Isadora 3 User Actors/Macros vs. Isadora 2 User Actors/Macros

Isadora 3 User Actors/Macros now save with the extension ".iau3". (These cannot be used in Isadora 2.)

Isadora 2 (".iua") User Actors/Macros can be used in Isadora 3, but when you save them, Isadora 3 will save copies of them with the new extension ".i3ua" rather than overwriting your Isadora 2 ".iua" User Actor/Macros. This will prevent accidentally overwriting Isadora 2 User Actors/Macros while using them in Isadora 3 (which would otherwise make them unusable in Isadora 2).

FreeFrame (FF) and FreeFrameGL (FFGL) Plugins

Pete's FreeFrame Plugins are no longer supported in Isadora 3.

The Actor ToolBox Filter for FFGL filter was removed because 64-bit FF plugins are rare/non-existent, so "FF" now contains all FreeFrame plugins, GL or otherwise.

Isadora Plugins

Artnet Plugins

The ArtNet Plugins have been updated to 64 bit. 

Rutt-Etra Plugins

Mark is working on updating Rutt Etra to 64 Bit

TroikaTronix GLSL Shaders

  1. GLSL Shaders can be used in both Isadora 2 and 3.

  2. There are two new Troikatronix GLSL Shaders! TT Edge Blend (which will be fixed shortly) and TT RGB Modulation.

  3. We are working on cool, new example patches for the TroikaTronix GLSL Shaders.

  4. You can learn how to use GLSL Shaders from this TroikaTronix Knowledge Base Article.

New Actor Toolbox Filter: Color

There is a new Toolbox Filter called color that contains the different actors used for color conversion. Please note that actors that generate video, such as “Background Color”, have remained in Video Effects.

Get Stage Image Actor - NEW Actor

The Get Stage Image actor captures the output of any Stage or Virtual Stage and makes it into a GPU video stream that you can then route back into your patch.

Value Changed Actor - NEW Actor

The Value Changed actor compares each incoming value to the last value that was output. If the difference between those two values is greater than or equal to the “min chg” property, then the value is passed to the ‘value out’ output and a trigger is sent to the ‘trigger’ output.

Javascript Actor - Renamable Inputs and Outputs

Mark has added the ability to name the inputs and outputs on the Javascript actor for Isadora v3. Like the GLSL shader, the approach to this is to use a special comment format; in this case a "//" followed by either “iz_input” or “iz_output”, the input or output number, and then the words you want to appear for that title. Here's an example:

// iz_input 1 "custom first input"
// iz_input 2 "custom second input"
// iz_output 1 "custom first output"
function main()
{
    return arguments[0] + 1;
}

Live Drawing Actor - New Input and Renamed Inputs

The ‘reset stroke’ input has been renamed ‘erase curr’. It erases the current stroke.

NEW INPUT: An input named ‘erase last’ has been added. It erases the last stroke.

The ‘reset’ input has been renamed ‘erase all’. It erases all the strokes.

Measure Color Actor - Added Alpha Output

The Measure Color actor now has an "alpha" output parameter.

Shuffle Actor - Limit Added

The Shuffle actor has been limited to 1,000,000 items and we updated the help text to indicate this.

Renamed Actors

  1. The actor previously named "Classic 3D Renderer" in Isadora 2.6.1 has been renamed "Classic 3D CPU Renderer" and is still deprecated in Isadora 3. (Deprecated as of Isadora 2)

  2. The actor previously named "Virtual Stage" in Isadora 2.6.1 has been renamed "3D Renderer" and is newly deprecated in Isadora 3. (Deprecated as of Isadora 3)

    • Due to the new Virtual Stages in the Stage Setup, the name of the Virtual Stage actor was changed to 3D Renderer. 

    • This actor has been marked as deprecated in Isadora 3 because it is not really needed anymore. 

    • Though the newly-renamed "3D Renderer" actor will still continue to function, Virtual Stages now exist as part of the Stage Setup and all the orientation-control aspects of the actor can be handled by a 3D Stage Orientation actor.

    • Throughout the program, all references to the "Virtual Stage" actor have been changed to "3D Renderer" and the other 3D actors now refer to it as a 'renderer'.

  3. The actor previously named "Capture Camera to Disk" in Isadora 2.6.1 has been renamed "Capture Camera to Movie" in Isadora 3.

  4. The actor previously named "Data Array" in Isadora 2.6.1 has been renamed "Classic Data Array" and is newly deprecated in Isadora 3. (Deprecated as of Isadora 3)

    • There is a new version of the same actor in Isadora 3, still called "Data Array", that is better equipped to deal with extremely large datasets. (New as of Isadora 3)

  5. The actor previously named "Stage Size" in Isadora 2.6.1 has been renamed "Get Stage Size" in Isadora 3.

Removed Classic/Legacy Actors

All Classic Movie Player actors will no longer function. Unfortunately, removing the older QuickTime dependencies within the program meant that we had to remove a number of classic (i.e. "legacy/deprecated") Isadora actors. These actors were CPU-based, had already marked as deprecated in 2.6.1, and have been removed in Isadora 3:

  1. Classic External Video Output 

  2. Classic Movie Player Direct 

  3. Classic Movie Player Direct Core

  4. Classic Movie Player Direct Device 

  5. Dither 

  6. Image Tile 

  7. Movie Player VR 


Updating Files to Isadora 3

When updating an old Isadora patch to Isadora 3, the program will attempt to replace the removed and classic cpu-based actors with their newer, GPU-based equivalents if possible.

Additionally, whenever you open an old file in a never version of Isadora, the default prompt offers to create and open a copy, leaving the original file unchanged so that you can still open it in the version in which it was created.


Main User Interface Updates

Stage Status Indicator

When you hot plug/unplug a display it forces Isadora to hide and then unhide the Stages and thus we felt some kind of feedback about the Stages was needed in the main UI. Down at the bottom right of the main application window, next to “Cycles”, Mark has added an indicator for the current Stage Status.

If the Stages are shown, this will say either "FULL" for fullscreen mode or "PREV" for preview mode, otherwise this indicator will say "OFF".

LOAD Indicator

At the bottom right of the main application Window, Mark added a visual indicator that should help gauge when you are running up against hardware limitations or inefficient patching.

The “LOAD” bar indicates how long it is taking to render each frame, specified as a percentage of the available time per frame at the Target Frame Rate.

When your patch is running smoothly, this indicator will be green and the percentage value will be somewhere below 50%. If your patch is starting to reach your the limits of computer's hardware capabilities, you will see this number rise and the indicator will turn yellow. If this indicator turns red and the percentage is near or above 100%, you should revise your patch to lessen the load on your hardware.

Short version: The bar transitions in color from green to red as the load increases. Small number + green bar = good, BIG NUMBER + RED BAR = BAD

Theme Editor

For the first time ever you can create your own custom themes for Isadora.

To access this feature, go to the menu in Isadora and select View > Show Theme Editor.

You can select a different theme to use by going to the menu in Isadora and selecting View > Themes.

You can move your themes between computers by going to the menu in Isadora and selecting View > Open Themes Folder and then copying the files to another computer.

Here are some Isadora Themes made by Ryan Webber (Dusx) which are available on the TroikaTronix Plugin Page.

DX - Rustbelt (Click the name to download)

DX - Live10 (Click the name to download)

Isadora Preferences Updates

Reset Isadora Preferences from the Isadora Menu.

Isadora 3 adds two new options to the Isadora menu, “Reset Preferences” and “Open Preferences Folder”. These were added for technical support reasons and make it much easier for users to reset and/or backup their Isadora Preferences files.

Go to the menu in Isadora and select Isadora > Reset Preferences and Isadora > Open Preferences Folder. After you reset your Isadora Preferences, make sure that you close and re-open Isadora to complete the process.

Isadora > Reset Preferences

Isadora > Open Preferences Folder

Display Refresh Lock

To see this setting, go to the menu in Isadora and select Isadora > Isadora Preferences > General > Frame Rate / Tasks > Display Refresh Lock

Isadora 3 includes a new setting “Display Refresh Lock” in Isadora Preferences for macOS. It allows you to choose if Display Refresh Vsync is Off or On, with two different options for on.

  1. If this option is set to Off, Isadora uses the 'traditional' Target Frame Rate. The internal or external displays should have no affect.

  2. If this option is set to Scale, Isadora will lock to a scaled down frame rate. It will reference the of the external display(s) if present, or the internal display's refresh rate otherwise. For this option, Isadora will automatically scale the refresh rate so that it falls in the 24-30 fps range.

  3. If this option is set to Full, Isadora will lock to the frame rate of the external display if one is present, or the internal display otherwise. Note that this is labeled "May Reduce Performance".

  4. If you are set to Scale or Full with no external monitor present, but then you plug one in, Isadora will switch the lock to reference the external display automatically.

User Interface Timecode Settings

To see these settings, go to the menu in Isadora and select Isadora > Isadora Preferences > General > User Interface > Timecode Rate for New Files / Actors Default to Using Timecode

With the addition of timecode, there are a couple new Isadora Preferences that relate to timecode; "Timecode Rate for New Files" and "Actors Default to Using Timecode" (both of which are pretty self-explanatory).

Scale to Default Resolution 

To see this setting, go to the menu in Isadora and select Isadora > Isadora Preferences > Video > Scale to Default Resolution.

This has been marked "Legacy" and raises a warning. It was intended for use with the outdated CPU-based plugins. 

Stage Setting

To see these settings, go to the menu in Isadora and select Isadora > Isadora Preferences > Stage

Almost all of the settings from the Stage tab of Isadora Preferences were moved to Output > Stage Setup.

Warnings

To see these settings, go to the menu in Isadora and select Isadora > Isadora Preferences > Warnings

There is a new warning for when "When Combining Video" is set to "Scale to Default Resolution" as this is a legacy setting and should not be used.

There is a new Mac-only warning that occurs if "Displays Have Separate Spaces" is enabled in your System Preferences.

There is a new Windows-only warning that occurs if "Windows Peek" is enabled.

The following warnings were no longer relevant and have been removed:

  1. "When video input resolution is too high"
  2. When the preferred QuickTime Audio mode is not enabled."

Control Updates

Defaults for certain controls were changed to minimize setup time and speed up workflow. 

Scene Select Control

  1. “Click Activates Scene” now enabled by default (in 2.6.1 default was disabled)

  2. “Lines Before Current” now defaults to “0” (in 2.6.1 default was 2); eliminated superfluous spaces before current Scene

Bin Picker Control

  1. Default size is larger; accommodates 4x2 grid of video files (in 2.6.1 the default was tiny and had to be expanded)

  2. Media Type default is “Video” (no change) with “Display All of Selected Type” enabled by default (New)

  3. Media Type now includes “3D Model”

  4. Default Item Width was doubled to make it more usable.

Media View Panel Updates

Auto-Adjust Media Numbers state is now remembered upon re-opening a file.

The HQ and SQ flags were removed (they were a QuickTime feature)

Media Info

Mousing over media in the Media View now gives a "rating" of reverse playback and interactive control (scrubbing) for each video file on a scale of POOR-GOOD-BEST


Miscellaneous Updates

Serial Connections Updates

Isadora 3 adds ability to use a wider range of COM ports on PC.

Keyboard Shortcut Updates

Zoom

  1. Cmd/Ctrl + "-" is now Zoom Out

  2. Cmd/Ctrl + “+” is now Zoom In

  3. Cmd/Ctrl + “0” is now Default zoom

  4. These same keyboard shortcuts now have been added to the "hotkey" commands in IzzyMap and the Stage Setup.

  5. This means that the zoom shortcut keys are now the same everywhere: Scene/Control Editors, IzzyMap and Stage Layout.

  6. The zoom menu shortcuts are only active when you have focused on that view. (I.e., if you're focused on the table view, they don't operate.) To reinforce this, Mark added a focus indicator to the Stage Setup that is the same as Izzy Map (blue border).

  7. When the zoom shortcuts are not valid, they will now grey out properly.

Others

  1. Alt+click and drag now drags in the Scene Editor, IzzyMap, and Stage Setup.

  2. Alt+scroll wheel now zooms in and out in the Scene Editor, IzzyMap, and Stage Setup.

  3. Cmd/Ctrl-Shift + "+" is now Expand Actor shortcut

  4. Cmd/Ctrl-Shift + "-" is now Collapse Actor shortcut

  5. Cmd-Option + M / Ctrl-Alt + M is now Midi Setup Window shortcut (formerly Cmd/Ctrl + 0)

  6. Cmd/Ctrl + 9 is now Stream Setup (formerly Cmd/Ctrl + 4) - (This was changed because Serial Port Setup is Cmd/Ctrl + 8)

  7. Cmd-Option + O / Ctrl-Alt + O is now All Notes Off

Menu Option Updates

Additions/Changes

  • Isadora > Reset Preferences (New Feature)

  • Isadora > Open Preferences Folder (New Feature)

  • View > Timecode (New Feature)

  • View > Show Theme Editor (New Feature)

  • View > Open Themes Folder (New Feature)

  • Actors > Detach Links at Input (Renamed from "Reconnect Link")

  • Actors > Detach Links at Output (New Feature)

  • Actors > Set Time Options > Use Timecode / Use Percentage (for Movie Player, New Feature)

  • Output > Stage Setup (Cmd/Ctrl + 2, replaces the old Stage Setup)

  • Help > Activate... (in Demo Mode, New Licensing System)

  • Help > Deactivate... (on a computer that has already been activated, New Licensing System)

  • Help > Offline Activation... (New Licensing System)

  • Help > Offline Deactivation... (New Licensing System)

  • Help > Go to License Portal… (New Licensing System)

  • Help > Register… (Now only visible in USB + Demo Mode Version)

  • Help > Upgrade… (Now only visible is USB + Demo Mode Version)

  • Help > Download Plugins... (Renamed from “Get Additional Plugins...”)

  • Help > Contact Support... (Renamed from “Submit Bug Report…”)

Permanently Removed

  1. Isadora Preferences > Video > Video Input Settings > Load/Save All Settings When Starting/Stopping Live Input (QuickTime feature, Removed)

  2. Isadora Preferences > Video > External Video Output (Legacy Feature, Removed)

  3. Isadora Preferences > Video > OpenGL > Shared OpenGL Resources (Removed for now)

    • Option has been removed and this setting is now forced on, even if you loaded Isadora Preferences where it used to be turned off

    • Tests have shown that Isadora works with this enabled on a machine using multiple identical graphics cards.

    • Tests have shown that Isadora 3 does not work with this disabled on a machine using multiple graphics cards that are not identical.

    • This may be re-implemented later.

  4. Isadora Preferences > Stage > Preview Stage Size (Moved to the top of the Stage Setup)

  5. Isadora Preferences > Stage > Stages (Moved to Output > Stage Setup > Stage List)

  6. Isadora Preferences > Stage > Stage Preview Control Settings (Moved to Output > Stage Setup > Stage/Display Settings)

  7. Isadora Preferences > Warnings > When video input resolution is too high (Legacy warning from Isadora 1)

  8. Isadora Preferences > Warnings > When the preferred QuickTime Audio Mode is not enabled (QuickTime-based, Removed)

  9. Scenes > Edit Go Triggers > Keyboard > Key Select, use of arrow keys as "Go Triggers" (Interfered with some basic navigation functions, all arrow keys removed from list of possible keyboard "Go Triggers")

  10. Scenes > Edit Go Triggers > Keyboard > Key Select, use of Tab (Interfered with some basic functions, removed for list of possible keyboard "Go Triggers")

  11. Output > OLD Stage Setup (Removed, functions moved to Output > Stage Setup)

  12. Output > Stage Live Edit (Removed, functions moved to Output > Stage Setup > Stage/Display Settings)

  13. Output > Compression Settings (Removed and settings combined into “Output > Record Stage Settings”)

  14. Output > External Video (Legacy, Removed)

  15. Output > External Video Out Device (Legacy, Removed)

  16. Output > External Video Out Mode (Legacy, Removed)

  17. Media View > HQ and SQ Flags (QuickTime-based, Removed)

Removed (to be re-implemented in the near future)

  • Output > Sound Output Setup (Removed temporarily for a re-work)

  • Input > Live Capture Settings > Sound Input  (Removed temporarily for Windows)

Newly Available

64-bit Rutt-Etra Plugin is Available

The 64-bit Rutt-Etra plugin for Isadora 3 is available on our plugins page.

Send PJ Link Plugin is Available

The Send PJLink actor allows you to control a PJLink compatible projector. You can get the plugin from our downloads page.


Coming Soon!

NDI Input Support!

NDI input for Isadora 3 will come in the form of a new plugin and will be released on the new Plugins page when it is completed.

Body Tracking Plugins

We are still finalizing development on depth-image capture from Orbec Astra, Kinect, Kinect v2, and RealSense cameras. We will release these as they are completed on our new Plugins page. 

Codec Support

H265.mkv

Cool new example patches for the TroikaTronix GLSL Shaders!

An All-New Video Tutorial Series!

Reworked Advanced Sound Support

We are still working on the implementation of some of the more advanced sound features from Isadora 2. The reason for this is that they were QuickTime-dependent, and as we have dropped QuickTime, we will need to take the time to re-create these features (such as Sound Output Settings).

The good news is that we have found a new sound library called SoLoud. Here's why it's great:

  1. Everything involved in this library is liberally open sourced; no GPL or LGPL.

  2. Unlike a lot of libraries out there, it allows you to play multiple voices and to control each voice's volume, pan and pitch -- exactly what we needed!

  3. Implied by the pitch change feature, this library does resampling (though they may not yet be of the highest quality) which MOST of the others (PortAudio, libSndIO) do not give you.

  4. It supports a huge range of backends to actually get the sound out to devices like XAudio2 (Win), Port Audio, CoreAudio (Mac) and several others.

  5. It features emulators for some old gaming chips (VIC-20 anyone?) but -- best of all in this category -- this incredible funky, retro sounding voice synthesizer which I didn't need at all but will not be able to resist putting into Izzy. ;-)

  6. Both the Windows and the Mac version of Isadora use SoLoud, and while the AU actors are still Mac only, it is a big step forward for us to have the Mac and Windows sound systems using the same library.

So while the release version of Isadora 3 may be a bit of a step backward in terms of advanced audio features, we assure you that we're aware of this and that we've already laid the groundwork to start rebuilding the features we lost when we cut QuickTime out of the program.


3.0.2 Release Notes (July 22nd, 2019)


MacOS Multichannel Sound Support

  • MacOS multi-channel sound support has been reinstated, which means that there is now an item in the output menu labeled "Sound Output Setup" again, which functions on MacOS and shows a "not implemented" alert on Windows. However, this is a temporary solution, eventually we hope to add multi-channel sound support using the SoLoud library so it can be cross-platform.

Bug Fix, Plugin - OSC Multi Transmit plugin - OSC Multi Transmit Will Not Send Mixed Types is fixed. (Issue present in 2.6.1.)

Bug Fix, Plugin - Activate Scene - “transition” input re-added.

Bug Fix, Plugin - Activate Scene Amount - “transition” input re-added.

Bug Fix, Plugin - Stage Mouse Watcher - actor now functions in full screen, non-blended displays, and preview windows.

  • Here is a handy patch that reports information and blinks different colors when you left and right click. It contains user actors in which you can set the number of displays across and down, and then input the horz pos/vert pos to replicate the information on multiple displays.

Bug Fix, Plugin - JavaScript - Issue where Javascript lost color formatting when moving the window between displays was fixed.

Bug Fix, Plugin - JavaScript - Issue where Javascript editing was very sluggish was fixed.

Bug Fix, Plugin - JavaScript+GLSL Shaders - Issue with undo not functioning properly was fixed.


Cosmetic Fix, Plugin - Alpha Tool - Fixed a few typos and clarified the settings for the "action" input.

Cosmetic Fix, Plugin - Sound Frequency Watcher - Fixed a  typo.

Cosmetic Fix, Dialog - "Isadora has experienced an unexpected error" - Fixed a  typo on Mac.


Feature Added - 32-bit Plugin Warning - On Windows 10 Isadora 3 will now warn you if you attempt to start up with one or more 32-bit plugins in an Isadora 3 plugin folder, give you their names, and give you the option to open the relevant folder to remove the offending plugin(s).

Feature Added - Stage Setup - Added a "Reset" button for the curves on blended Stages


Bug Fix, Feature - IzzyMap - Publishing IzzyMap points using the trackpad ‘ctrl+click’ and right-click fixed.

Bug Fix, Feature - IzzyMap - Scrolling through the list of mapping slices with the mouse wheel/trackpad fixed.

Bug Fix, Feature - IzzyMap - A scrollbar now appears if you add a large number of mapping slices

Bug Fix, Feature - IzzyMap - IzzyMap window is now auto-closed if the Projector actor is selected and reset via the menu option "Reset to Default Values"

Bug Fix, Feature - Blind Mode - Can now edit actors pasted into a Scene while in Blind Mode.

Bug Fix, Feature - Floating Stage Previews - Preview Windows weren't updating their configuration once they'd been shown. Now, if you change Shared OpenGL Resources, Full Frame Antialiasing, Disable Vertical Retrace Sync, or Floating Stage Windows, and the preview windows are visible, Isadora will hide them and show them automatically.

Bug Fix, Feature - Rebuilt Media From Folder - Wasn't working in 3.0.1, but has been fixed on Mac and Windows for 3.0.2.

Bug Fix, Feature - Stage Setup - Default Preview Size percentage maximum limited to 100%.

Bug Fix, Feature - Detach Links at Output/Input - Issue where certain actions (mostly zooming/moving in the Scene Editor) would interfere with this feature is now fixed.

Bug Fix, Feature - Issue where pressure was not being read from Wacom tablets is now fixed.


Crash Fixes

Crash Fix - Control Panel - Selecting a Control and choosing “Send to Back” no longer causes a crash.

Crash Fix - Startup Crash - Fixed a Mac-only issue where having certain variants of "Vollkorn" font installed on Mac would cause a crash on startup.

Crash Fix - Reset to Default Values - Publishing an IzzyMap point, selecting the Projector actor, then selecting "Reset to Default Values" caused a series of assertion dialogs. (Issue present in 2.6.1.)

  • This affected more than just the Projector actor; similar crashes/problems were present with the Selector actor if you set the number of inputs to 3 and then perform the reset. In both cases, if you had links connected to the inputs that disappear because of the reset, they would be lost and not restored during undo. 

Crash Fix - IzzyMap - Fixed some issues relating to the Grid mapper slice options


Menu, Cosmetic - Menu: Isadora > Isadora Preferences (Dialog) > Warnings > When there is no audio output and the Sound Player is disabled - Added "(Windows Only)"

Menu, Cosmetic - Menu: Isadora: Isadora Preferences (Dialog): Warnings: When "Displays have separate Spaces" is Enabled (Mac Only) - Fixed capitalization

Menu, Cosmetic - Menu: Isadora > Isadora Preferences (Dialog) > Warnings - The last two warnings in this list no longer visually overlap

Menu, Change - Menu: Output > Sound Output Setup… - This menu option has returned (and as in 2.6.1 is Mac only).

Menu, Cosmetic - Menu: Help > Open Plugin Folder > TroikaTronix GLSL Shaders - "TroikaTronix Shaders" menu option renamed "TroikaTronix GLSL Shaders" for the sake of clarity


3.0.6 Release Notes (November 6, 2019)

Download links are at the bottom of this section. Please read the release notes first!


New Features

Force a Preview To Be Shown for any Stage or Display 

Because a number of users gave us feedback saying that this was important to their workflow, we added a new "Force On" Checkbox to the Stage Setup settings. Checking it allows any Stage or Display to always show a preview window. 


Force Preview is Shown for Stage If Any of Its Associated Displays Are Missing

Like v2.x, Isadora 3 now shows a preview window for a Stage if any of its associated displays are not available. Unlike Isadora 2, where each Stage was associated with a single display, Isadora 3 allows a multiple displays to be associated with a Stage to facilitate edge blending. If any of those displays are not present when choosing the "Show Stages" command from the Output menu, a preview for that Stage will be shown. If all of the displays associated with a Stage are present, then a preview window will be shown only if the Stage's "Force On" checkbox is checked.


Listener Actors support custom data types ('blob', 'blob-list', 'skeleton' etc.)

To use these types, you must choose the new 'data' type for the 'type' input. Note that just choosing this does not allow you to connect to the object you desire; you can only do this once a value has actually been received.



Plugin Version Numbers 

TroikaTronix Isadora Plugins are now compiled with their own unique version numbers. Now, the automatic or manual update check will now report updates for those plugins. 

There are also three ways to see this version number within the program itself:

1) Mouseover the actor and the version number will show up after the actor's name in the Media View Info Panel.

2) Right-Click on the actor and select "Actor Help" from the right-click menu.

3) Cmd + Option + Left-Click actor and the Actor Info will show up in a dialog over the Actor.



Timecode Supported in the Isadora Control Panel

We have continued to integrate Timecode into Isadora this release. 

The Control Panel has a new Control called “Timecode” which can properly send,  receive, and report Timecode values.

In addition, actor properties which use Timecode values can now be assigned Control IDs to send, receive, or report Timecode numbers from Control Panel actors.

 

Timecode support has also been added for the Listener, Broadcaster, Net Broadcaster, Set Global Values, and Get Global Values actors.


Live Drawing Actor: New ‘Fade Out’ Feature 

You can now fade out previous parts of the drawing if desired using the 'fade active', 'fade hold', and 'fade out' inputs.



MacOS - HID Stream Setup Display is Prettier

We’ve made a few changes to the HID Stream Setup, which makes sure that the name of the button/joystick shown in light grey text instead of black on a dark grey background and changed the color of the graph to make it more aesthetically pleasing.


Control Left Click now treated as Right-Click (macOS)

Isadora 3.0.6 now recognizes Control + Left-Click as a Right-Click. This combination is standard but not implemented by macOS automatically. This only works if only the control key is down; holding down other modifiers prevents this from being a right click. Previous versions of Isadora 3 did not recognize this combination.


Option/Alt-Click to Update Snapshots

Isadora 3.0.6 has changed the modifier key used to update snapshots to the option key (macOS) or alt key (Windows). In previous versions of Isadora, the control key modifier was used.


Bug Fixes

- Fixed a bug which prevented the Listener, Broadcaster, Net Broadcaster, and Set/Get Global Values from transmitting Timecode values.

- Fixed a bug where the Text Formatter actor was not properly updating its output if the inputs didn't change upon activating its Scene.

- Fixed a bug where a link would not revert its color back to red after being activated if (and only if) the actor was collapsed so you couldn’t see the input or output values.

- Fixed an issue where Hiding Actor Properties using Show/Hide Properties did not work.

- Fixed bug in syntax coloring in Javascript / GLSL editors.

- Fixed an issue where entering a value in a value slider, then using the numpad Enter Key raised an error.

- Fixed an issue where the OSC Multi Transmit actor could not send more than ~40 values.

- Fixed a bug where auto-scrolling when dragging to the edge of the Scene Editor or Control Panel would not work unless you moved the mouse around a bit.

- Fixed a bug where the Sound Player actor would not play sounds in folders with Unicode characters.

- Fixed a bug which caused NDI Output to be scrambled if the Output Size was not divisible by 16.

- Fixed several issues when inputting or outputting Timecode values with User Actors.

- Fixed an issue where enabling 3d on Projector actors disables 3D if Z-Translate is zero.

- Fixed a macOS bug where the user interface would occasionally freeze so that actors and panels couldn’t be interacted with or moved.

- Fixed a macOS bug so that Isadora now correctly deletes text selection after double-clicking a word and pressing delete. 

- Added HID Input support for macOS 10.15.x Catalina.


Crash Fixes

- Fixed a macOS bug which caused Isadora crashes on startup on macOS Catalina. Note that versions of Isadora prior to 3.0.6 cannot be used on macOS 10.15.x Catalina.

- Fixed a macOS bug which caused Isadora crashes under Catalina when dragging AVI Files (notably HAP files with sound).

- Fixed a bug where macOS trackpad gestures could cause Isadora to crash.

- Fixed a crash which could sometimes occur when undoing movements of User Inputs and Outputs.

- Fixed a bug where re-linking the Rutt Etra plugin to a Movie Player actor caused Isadora to crash.

- Fixed a bug which caused Isadora crashes when Closing a User Actor and ‘Choosing Save and Update All’.

- Fixed a bug which caused Isadora crashes on quit if another app or device was sending a stream of OSC bundles. 

- Fixed a Windows bug which caused Isadora crashes when exiting a scene where the Movie Player actor had a slow or negative speed. 

- Fixed a Windows bug which caused Isadora crashes when activating a Scene containing a Movie Player actor playing an audio only movie with the speed set to zero. 


Miscellaneous

Activation Refresh for Subscription Licenses

For Isadora Users with Subscription Licenses, Isadora 3 must check in to our subscription server via the internet at least once every two weeks to authenticate your subscription. Otherwise, Isadora reverts to Demo Mode. We’ve added a warning message if Isadora hasn’t been online for at least two weeks to remind you to connect to the Internet to authenticate your subscription. Once this warning message appears, you have a three-day grace period to connect to the Internet while running Isadora before it reverts to Demo Mode.

If you’re working on a machine which is regularly online, you’ll never see this message. The Isadora Perpetual Edition is strongly recommended for computers which are not regularly connected to the Internet.


Isadora Now Alerts User if OpenGL Version is less than v2.0 (Windows Only)

If a Windows user attempts to run Isadora and the video drivers report that the OpenGL version is less than v2.0, a dialog indicating this and a dialog asking the user to upgrade their video drivers will be shown. Isadora quits as soon as the user clicks OK in this dialog, as it is impossible to continue. MacOS will never show this dialog.


Sassafras Version no longer shows “Demonstration Mode” while Starting up

Isadora now says "Connecting to Server..." as it should to let the user know it's trying to reach the Sassafras Keyserver.


Isadora 3.0.6 and macOS Catalina (v10.15) 

If you are running macOS 10.15 Catalina, you must work with Isadora v3.0.6 or later. Earlier versions of Isadora 3 and Isadora 2 are not supported on Catalina.

We are confident to recommend Isadora 3.0.6 to Catalina users who are developing new pieces, or using it in workshops or teaching environments.

However, like many industry leaders, we strongly advise you to hold off on upgrading to Catalina if you are working in a professional performance environment. Because of substantial changes to security protocols in Catalina, and because of numerous, serious issues this new version of macOS exhibited during its development cycle, we feel you should wait for a few more updates to come out before you make the switch.



Download Links

macOS

Isadora 3.0.6 - Standard Version
Isadora 3.0.6 - USB Key Version

Windows

Isadora 3.0.6 - Standard Version

Isadora 3.0.6 - USB Key Version